This is my totally destructive solution to having trouble mounting or reading a Sandisk Cruzer Glide 64GB. If you care about what’s on your USB stick, this is not for you.
Background
I wanted to used Balena Etcher to create a bootable Ubuntu stick. But MacOS couldn’t mount it. I tried all the Disk Utility GUI’s First Aid and Erase features but nothing worked. DU could see the drive, but couldn’t do anything with it.
Re-formatting seemed to work – from the CLI
I was finally able to get MacOS Catalina to reformat the stick into something mountable and readable by using diskutil
from the command line.
First, figure out where your USB stick is:
$ diskutil list
In my case, my USB stick was at /dev/disk2
. Here, we re-format using the Mac OS Extended filesystem. To see all your available options use the diskutil listFilesystems
command.
$ sudo diskutil eraseDisk HFS+ NEWNAME /dev/disk2
Note about Filesystem
I had originally formatted using the APFS filesystem, but that caused balena etch to fail with an odd message “EBUSY: resource busy or locked, open ‘/dev/rdisk2
“. Turns out balena did not like APFS. Reformatting with HFS+ solved the problem and I was able to successfully create my Ubuntu image.